HTML Training Part I: Welcome to Dreamweaver

Windows, Panels and Menus Overview 
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The following are brief descriptions of the windows and other elements in Dreamweaver. 

TOOLBARS

The Insert bar contains buttons for inserting various types of “objects,” such as images, tables, and layers, into a document. Each object is a piece of HTML code that allows you to set various attributes as you insert it. For example, you can insert an image by clicking the Image icon in the Insert bar. If you prefer, you can insert objects using the Insert menu instead of the Insert bar. 

The Document toolbar contains buttons and pop-up menus that provide different views of the Document window (such as Design view and Code view), various viewing options, and some common operations such as previewing in a browser. 

The Document window displays the current document as you create and edit it. 

The Property inspector lets you view and change a variety of properties for the selected object or text. Each kind of object has different properties. 

Panel groups are sets of related panels docked together under one heading. To expand a panel group, click the expander arrow at the left of the group’s name; to undock a panel group, drag the gripper at the left edge of the group’s title bar. 

Dreamweaver provides many other panels, inspectors, and windows not shown here, such as the History panel and the Code inspector. To open Dreamweaver panels, inspectors, and windows, use the Window menu. 

MENUS

The File menu and Edit menu contain the standard menu items for File and Edit menus, such as New, Open, Save, Cut, Copy, and Paste. The File menu also contains various other commands for viewing or acting on the current document, such as Preview in Browser and Print Code. The Edit menu includes selection and searching commands, such as Select Parent Tag and Find and Replace, and provides access to the Keyboard Shortcut Editor and the Tag Library Editor. The Edit menu also provides access to Preferences, except on the Macintosh in Mac OS X, where Preferences are in the Dreamweaver menu. 

The View menu allows you to see various views of your document (such as Design view and Code view) and to show and hide various kinds of page elements and various Dreamweaver tools. 

The Insert menu provides an alternative to the Insert bar for inserting objects into your document. 

The Modify menu allows you to change properties of the selected page element or item. Using this menu, you can edit tag attributes, change tables and table elements, and perform various actions for library items and templates. 

The Text menu allows you to easily format text. 

The Commands menu provides access to a variety of commands, including one to format code according to your formatting preferences, one to create a photo album, and one to optimize an image using Macromedia Fireworks. 

The Site menu provides menu items to create, open, and edit sites, and (on the Macintosh) to manage files in the current site. 

The Window menu provides access to all of the panels, inspectors, and windows in Dreamweaver. 

The Help menu provides access to Dreamweaver documentation, including help systems for using Dreamweaver, creating extensions to Dreamweaver, and reference material for a variety of languages. 

Create and save a new page 

To create a new page: 

1. Choose File > New.

2. Select “Blank”. (This process varies depending upon Dreamweaver’s settings).

To save your new page: 

1. Choose File > Save. 

2. In the Save As dialog box, browse to your chosen folder.

3. Enter the filename.

4. Click Save.

About images 

Many different types of graphic file formats exist, but two graphic file formats are generally used in web pages—GIF and JPEG. 

GIF (Graphic Interchange Format) files use a maximum of 256 colors, and are best for displaying noncontinuous-tone images or those with large areas of flat colors, such as navigation bars, buttons, icons, logos, or other images with uniform colors and tones. 

JPEG (Joint Photographic Experts Group) file format is the superior format for photographic or continuous-tone images, because JPEG files can contain millions of colors. As the quality of a JPEG file increases, so does the file size and the file download time. You can often strike a good balance between the quality of the image and the file size by compressing a JPEG file. 

Inserting an image

To insert an image: 

1. In the Document window, place the insertion point where you want to insert a graphic.

2. Do one of the following:

· In the Insert bar, select Common (top of bar) then click the Image icon.

· Choose Insert (from top menu selection) > Image.

3. Dialogue box appears.

4. Browse until you find image you would like to insert.

5. Click Select.

Note: Dreamweaver tracks location of both your HTML file and inserted images. If the image is outside of the root directory that your HTML file is in, a dialogue box will pop up asking if you would like to copy image into your root folder. 
Setting image properties 

This Property inspector allows you to set properties for an image. If you do not see all of the image properties as shown below, click the expander arrow in the lower right corner 

To set image properties: 

1. Set any of the following options:

· W and H are the width and height of the image, in pixels. Dreamweaver automatically updates these fields with the image’s original dimensions when you insert an image in a page. 

If you set W and H values that do not correspond to the actual width and height of the image, the image may not display properly in a browser. (To restore the original values, click the W and H field labels.)

· Src specifies the source file for the image. Click the folder icon to browse to the source file, or type the path manually. 

· Link specifies a hyperlink for the image. Drag the Point-to-File icon to a file in the Site panel, click the folder icon to browse to a document on your site, or manually type the URL. For information about creating links, see Creating links. 

· Align aligns an image and text on the same line. 

· Alt specifies alternative text that appears in place of the image for text-only browsers or for browsers that have been set to download images manually. For visually impaired users who use speech synthesizers with text-only browsers, the text is spoken out loud. In some browsers, this text also appears when the pointer is over the image. 

· Map Name and the Hotspot tools allow you to label and create a client-side image map. 

· V Space and H Space add space, in pixels, along the sides of the image. V Space adds space along the top and bottom of an image. H Space adds space along the left and right of an image.  

· Border is the width, in pixels, of the image’s border. The default is no border. 
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Inserting a table 

Use the Insert bar or the Insert menu to create a new table. 

To insert a table: 

1. In the Design view of the Document window, place the insertion point where you want the table to appear.

2. Do one of the following:

· Click the Table button in the Common category of the Insert bar.

· Choose Insert > Table.

3. Enter new values as desired.
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 Selecting & modifying table elements 

 To select an entire table, do one of the following: 

· Click on any of the table edges. 

· Click in a table cell, and then select the table tag in the tag selector at the lower left corner of the Document window.

· Click in a table cell, and then choose Modify > Table > Select Table. 

Adding content to a table cell 
You can add text and images to table cells the same way that you add text and images outside of a table.
Modifying table elements
You can change the width of a column or the height of a row by using the Property inspector. You can also change cell widths and heights directly in the HTML code using Code view. 

If you have trouble resizing, you can clear the column widths or row heights and start over. 

Property inspector: 

1. Select the column or row.

2. Choose Window > Properties to open the Property inspector.

3. Change the table element’s formatting by setting properties.
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Nesting tables 

A nested table is a table inside a cell of another table. You can format a nested table as you would any other table; however, its width is limited by the width of the cell in which it appears.

To nest a table within a table cell: 

1. Click in a cell of the existing table.

2. Choose Insert > Table.

3. In the Insert Table dialog box, specify the desired properties for the nested table, then click OK.

Nested tables are most often used when building complex pages. Any layout combination of artwork, text, animations, etc. can be broken out into a grid. Once this is done (visually, not in Dreamweaver) you simply insert elements into nested tables to achieve the final look. Similar to putting a puzzle together…

Nested tables with borders turned on
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Nested tables with borders turned off
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Setting background colors 

To set the background color of a table cell: 

1. Select the cell you want. 

The lower half of the Property inspector shows cell properties. If the lower half of the Property inspector isn’t visible, click the expander arrow at the lower right corner of the Property inspector to view all properties. 

2. In the Property inspector, click the Background Color button that appears next to the lower of the two Bg labels.

The color picker appears and the pointer changes to an eyedropper.

3. Select a color. You can either select a color in the color picker’s palette, or click anywhere on your display to select the color of the pixel you clicked. For example, click the background of the Global logo image to make the background color of the table cell match the image background color.

The table cell’s background color changes to the color you picked. 

4. Save your document.
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Adding text to a document 

There are a number of ways to add text to a Dreamweaver document. You can type text directly in the Dreamweaver document window, or you can cut and paste or import text from other documents.
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To add text to your document, do one of the following: 

· Type text directly into the Document window.

· Copy text from another application, switch to Dreamweaver, position the insertion point in the Design view of the Document window and paste.

Adding Spacing 

Dreamweaver works similarly to many word processing application: you press Enter (Windows) or Return (Macintosh) to create a new paragraph. Web browsers automatically insert a blank line of space between paragraphs. You can add a single line of space between paragraphs by inserting a line break. 

Setting and changing fonts and styles 
Use options in the Property inspector or the Text menu to set or change font characteristics for selected text. You can set the font type, style (such as bold or italic), and size. 

HTML font sizes are relative, not specific, point sizes. Users set the point size of the default font for their browsers; this is the font size that they will see when you select Default or 3 in the Property inspector or Text > Size submenu. Sizes 1 and 2 will appear smaller than the default font size; sizes 4 through 7 will appear larger. Also, fonts generally look larger in Windows than on the Macintosh, though Macintosh Internet Explorer 5 uses the same default font size as Windows. 
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To set or change font characteristics: 

1. Select the text. If no text is selected, the change applies to subsequent text you type.

2. Choose from the following options:

· To change the font, choose a font combination from the Property inspector or from the Text > Font submenu.

· To change the font style, click Bold or Italic in the Property inspector, or choose a font style (Bold, Italic, Underline, and so on) from the Text > Style submenu.
· To change the font size, choose a size (1 through 7) from the Property inspector or from the Text > Size submenu.
· To align text, highlight desired text and click on left, center, or right alignment options.
Changing the text color 

To change the color of text: 

1. Select the text.

2. Choose from the following options:

· Choose a color from the palette of browser-safe colors by clicking the color picker in the Property inspector.

· Choose Text > Color. The system color picker dialog box appears. Select a color and click OK.

· Enter the color name or hexadecimal number directly in the Property inspector field.

· To define the default text color, use the Modify > Page Properties command. 

To return text to the default color: 

1. In the Property inspector, click the color box to open the palette of web-safe colors.

2. Click the Strike-through button (the white square button with a red line through it, found in the upper right corner).
Creating links 
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The HTML tag for creating a hypertext link is called an “anchor” tag or an “a” tag. Dreamweaver creates an “anchor” tag for objects, text, or images you create links from. You can create links to other documents and files, and links to specific places in a single document using the “a href” tag. 

For example, if you select the text Home Page in the Document window, then create a link to a file named home.htm, the HTML source code for the link looks like this: 

<a href="home.htm">Home Page</a>

If you are creating a link to a specific place in a document, first create a named anchor (for example, a name="MainMenu"). Then create a link within the page that refers to that named anchor (for example, a href="#MainMenu"). 

You can create several types of links in a document: 

· A link to another document or to a file, such as a graphic, movie, PDF, or sound file. 

· A named anchor link, which jumps to a specific location within a document.

· An e-mail link, which creates a new blank e-mail message with the recipient’s address already filled in. 

· Null and script links, which enable you to attach behaviors to an object or to create a link that executes JavaScript code. 

Using Dreamweaver, create local links by:

· Use the Property inspector, by selecting text or a page element in the document, and then using the Property inspector folder icon or Point-to-File icon to select a file to link to or typing the path of the file.

· Manually type in path within source code.

Note: Make sure that you enter the entire path (including http://) when creating external links. 

Link to files and documents 

· Type the path and filename of the document in the Link text box.

· To link to a document in your site, enter a document-relative or site root-relative path. To link to a document outside your site, enter an absolute path including the protocol (such as http://). You can use this approach to enter a link for a file that hasn’t been created yet. 

Target of your link
From the Target pop-up menu, select a location in which to open the document.

To make the linked document appear somewhere other than in the current window or frame, select an option from the Target pop-up menu on the Property inspector: 

· _blank loads the linked document in a new, unnamed browser window.

· _parent loads the linked document in the parent frame or parent window of the frame that contains the link. If the frame containing the link is not nested, then the linked document loads in the full browser window.

· _self loads the linked document in the same frame or window as the link. This target is the default, so you usually don’t have to specify it.

· _top loads the linked document in the full browser window, thereby removing all frames.

Linking to a specific place in a document 
You can use the Property inspector to link to a particular section of a document by first creating named anchors. Named anchors let you set markers in a document, which are often placed at a specific topic or at the top of a document. You can then create links to these named anchors, which quickly take your visitor to the specified position. 

Creating a link to a named anchor is a two-step process. First, create a named anchor; then create a link to the named anchor. 

E-mail link 
An e-mail link opens a new blank message window (using the mail program associated with the user’s browser) when clicked. In the e-mail message window, the To field is automatically updated with the address specified in the e-mail link. 

To create an e-mail link using the Property inspector: 

1. Select text or an image in the Document window’s Design view.

2. In the Link text box of the Property inspector, type mailto: followed by an e-mail address. Do not type any spaces between the colon and the e-mail address. For example, type mailto:jdoe@macromedia2.com.
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Preview in browser 

The Design view gives a rough idea of what your page will look like in a browser, but the only way to be sure how it will look is to preview it in a browser. Each version of each browser has its own quirks; Dreamweaver strives to produce HTML that will look as similar as possible from one browser to another, but sometimes differences can’t be avoided. (That’s why Dreamweaver doesn’t display a preview directly; there’s no way for Dreamweaver to mimic all the different behaviors of all the different browsers.) 

Preview in Browser shows how the pages will look when you’ve published them. 

To preview your pages: 

1. Press the F12 key.

Your primary browser starts if it’s not running already. It displays the index page. 

Note: Dreamweaver should automatically detect your primary browser and use that for previewing. If the preview doesn’t appear, or if it doesn’t appear in the browser you expect, switch back to Dreamweaver (if necessary) and choose File > Preview in Browser > Edit Browser List. The Preview in Browser Preferences dialog box appears; add the correct browser to the list. For more information, click the Help button in the Preferences dialog box.

About document locations and paths 

Each web page has a unique address, called a Uniform Resource Locator (URL). (For more information on URLs, see the World Wide Web Consortium page on naming and addressing.) However, when you create a local link (a link from one document to another on the same site), you generally don’t specify the entire URL of the document you’re linking to; instead, you specify a relative path from the current document or from the site’s root folder. 

The three types of link paths are as follows: 

· Absolute paths (such as http://www.macromedia.com/support/dreamweaver/contents.html). See Absolute paths.

· Document-relative paths (such as dreamweaver/contents.html). See Document-relative paths.

· Site root-relative paths (such as /support/dreamweaver/contents.html). See Site root-relative paths.

Using Dreamweaver, you can easily select the type of document path to create for your links. 

Looking at the Code

Take a quick time-out for a look at what Dreamweaver is doing when you add content to a page. As you add text, images, and other content, Dreamweaver generates HTML code. 

Dreamweaver lets you view your document in either of two ways: Design view (where the document looks much like it would look in a browser), and Code view (where you can see the underlying HTML code). You can also use a split view that shows both Code and Design views. 

To view the HTML code for your document: 

1. If the Document toolbar isn’t already visible, choose View > Toolbars > Document.

2. In the Document toolbar, click the Code and Design view button.

The window splits, showing the underlying HTML code.

You can edit the code in Code view. Changes you make to the code don’t appear in Design view until you refresh the view. 

To make code changes appear in Design view, do one of the following: 

· Click anywhere in Design view.

· Click the Refresh button in the Document toolbar. 
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